Login issues accessing our Web Portal
Incident Report for Orca Security
Resolved
This incident has been resolved.
Posted Jan 17, 2023 - 12:17 UTC
Investigating
Orca Security is experiencing Login issues accessing our Web Portal.
Our engineers have been alerted and are currently working on providing a remedy for the issue.
Web Portal may be affected during this incident
Posted Jan 17, 2023 - 11:04 UTC
This incident affected: EU (Orca Dashboard, Orca Scanner Engine).