Increased Web Portal loading time detected in US environment.
Incident Report for Orca Security
Resolved
This incident has been resolved.
Posted Jul 14, 2023 - 16:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2023 - 16:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 14, 2023 - 15:56 UTC
Investigating
Orca Security is experiencing higher latency in access to our API and Web Portal in US environment.
Our engineers have been alerted and are currently working on providing a remedy for the issue.
Orca’s API and Web Portal may be slow or inaccessible during this incident.
Posted Jul 14, 2023 - 15:39 UTC
This incident affected: US (Orca Dashboard).