Increased Web Portal loading time in US environment

Incident Report for Orca Security

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 17:05 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2026 - 16:57 UTC

Identified

Orca Security is experiencing higher latency in our Web Portal in the US environment.

Orca’s Web Portal may be slow during this incident.
Posted Sep 03, 2026 - 16:49 UTC
This incident affected: US (Orca Dashboard).