Increased Web Portal loading time in EU environment

Incident Report for Orca Security

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 09:52 UTC

Monitoring

Orca Security is experiencing higher latency in access to our API and Web Portal in EU environment.

Our engineering team has been alerted and has already deployed a mitigation. During this time, users may experience slow performance or intermittent inaccessibility when using the API and Web Portal.
Posted Jun 30, 2026 - 09:17 UTC
This incident affected: EU (Orca Dashboard).