Increased Web Portal and API loading and response times in US environment

Incident Report for Orca Security

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 14:56 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2026 - 13:08 UTC

Identified

Orca Security is experiencing higher latency in access to our API and Web Portal in US environment.
Our engineers have been alerted and are currently working on providing a remedy for the issue.
Orca’s API and Web Portal may be slow or inaccessible during this incident.
Posted Jun 30, 2026 - 11:35 UTC
This incident affected: US (Orca Dashboard).