Increased Delay / Elevated Errors in APIs, UI and Asset Scanning in US environment

Incident Report for Orca Security

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 03:41 UTC

Update

The underlying AWS issue has been mitigated, and most AWS Service operations are succeeding normally now.
Posted Oct 20, 2025 - 11:03 UTC

Monitoring

We are aware of an ongoing AWS incident affecting services in the US-East-1 (N. Virginia) region.
AWS are investigating errors, as noted on their status page; https://health.aws.amazon.com/health/status

Our team continues to monitor the situation and review any potential impact on our systems. We will provide updates as more information becomes available.
Posted Oct 20, 2025 - 05:30 UTC
This incident affected: US (Orca Dashboard, Orca Scanner Engine, Orca Cloud Provider Platform, Orca Shift-Left Scans).