Verification is currently underway for the maintenance items.
Posted Aug 02, 2026 - 04:52 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 01, 2026 - 18:00 UTC
Scheduled
Orca Security will undergo scheduled maintenance on 1st August at 18:00 UTC for up to 24 hours, ending 2nd August at 18:00 UTC.
This maintenance affects the following regions: US, EU, AU, ID.
During this time, we will upgrade our RDS database infrastructure, including a version upgrade and capacity optimizations, to improve platform stability, reliability, and performance.
Scans will be temporarily unavailable during the maintenance window - new scans will not be triggered, and scheduled scans will be paused until maintenance is complete.
The UI and API are expected to operate in read-mode only, with a possibility of brief interruptions or slowdowns lasting up to few minutes.
Posted Jul 28, 2026 - 05:06 UTC
This scheduled maintenance affected: AU (Orca Dashboard, Orca Scanner Engine, Orca Cloud Provider Platform, Orca Shift-Left Scans), US (Orca Dashboard, Orca Scanner Engine, Orca Cloud Provider Platform, Orca Shift-Left Scans), EU (Orca Dashboard, Orca Scanner Engine, Orca Cloud Provider Platform, Orca Shift-Left Scans), and ID (Orca Dashboard, Orca Scanner Engine, Orca Cloud Provider Platform, Orca Shift-Left Scans).