Verification is currently underway for the maintenance items.
Posted Jun 14, 2026 - 14:03 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 14, 2026 - 06:00 UTC
Scheduled
Orca Security will be undergoing scheduled maintenance from the 14th of June at 6:00AM UTC for 12 hours, ending at the 14th of June, 6:00PM UTC.
During this maintenance window, we will be performing database restructuring to improve platform stability and scalability. The UI will remain available in read-only mode, though customers may experience intermittent slowness. Scan operations will be temporarily unavailable until the maintenance is complete.
Posted Jun 04, 2026 - 08:55 UTC
This scheduled maintenance affected: AU (Orca Dashboard, Orca Scanner Engine, Orca Cloud Provider Platform, Orca Shift-Left Scans) and IN (Orca Dashboard, Orca Scanner Engine, Orca Cloud Provider Platform, Orca Shift-Left Scans).